summaryrefslogtreecommitdiffstats
path: root/lass/5pkgs/bitlbee.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lass/5pkgs/bitlbee.nix')
-rw-r--r--lass/5pkgs/bitlbee.nix71
1 files changed, 71 insertions, 0 deletions
diff --git a/lass/5pkgs/bitlbee.nix b/lass/5pkgs/bitlbee.nix
new file mode 100644
index 00000000..2a5a8d86
--- /dev/null
+++ b/lass/5pkgs/bitlbee.nix
@@ -0,0 +1,71 @@
+{ fetchurl, stdenv, gnutls, glib, pkgconfig, check, libotr, python
+ , bitlbee-facebook ? null
+ , bitlbee-steam ? null
+}:
+
+with stdenv.lib;
+stdenv.mkDerivation rec {
+ name = "bitlbee-3.4.1";
+
+ src = fetchurl {
+ url = "mirror://bitlbee/src/${name}.tar.gz";
+ sha256 = "1qf0ypa9ba5jvsnpg9slmaran16hcc5fnfzbb1sdch1hjhchn2jh";
+ };
+
+
+ buildInputs = [ gnutls glib pkgconfig libotr python ]
+ ++ optional doCheck check;
+
+ configureFlags = [
+ "--gcov=1"
+ "--otr=1"
+ "--ssl=gnutls"
+ ];
+
+ postBuild = ''
+ ${if (bitlbee-steam != null) then
+ ''
+ mkdir -p $out/lib/bitlbee/
+ find ${bitlbee-steam}
+ cp ${bitlbee-steam}/* $out/lib/bitlbee/
+ ''
+ else
+ ""
+ }
+ '';
+ #${concatMapStringsSep "\n" ([] ++
+ # (if (bitlbee-facebook != null) then
+ # "cp ${bitlbee-faceook}/* $out/"
+ # else
+ # ""
+ # ) ++
+ # (if (bitlbee-steam != null) then
+ # "cp ${bitlbee-steam}/* $out/"
+ # else
+ # ""
+ # )
+ #)}
+
+ doCheck = true;
+
+ meta = {
+ description = "IRC instant messaging gateway";
+
+ longDescription = ''
+ BitlBee brings IM (instant messaging) to IRC clients. It's a
+ great solution for people who have an IRC client running all the
+ time and don't want to run an additional MSN/AIM/whatever
+ client.
+
+ BitlBee currently supports the following IM networks/protocols:
+ XMPP/Jabber (including Google Talk), MSN Messenger, Yahoo!
+ Messenger, AIM and ICQ.
+ '';
+
+ homepage = http://www.bitlbee.org/;
+ license = licenses.gpl2Plus;
+
+ maintainers = with maintainers; [ wkennington pSub ];
+ platforms = platforms.gnu; # arbitrary choice
+ };
+}