summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/haskell-overrides/irc.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/5pkgs/haskell-overrides/irc.nix')
-rw-r--r--krebs/5pkgs/haskell-overrides/irc.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/krebs/5pkgs/haskell-overrides/irc.nix b/krebs/5pkgs/haskell-overrides/irc.nix
new file mode 100644
index 00000000..b2088557
--- /dev/null
+++ b/krebs/5pkgs/haskell-overrides/irc.nix
@@ -0,0 +1,18 @@
+{ mkDerivation, async, base, bytestring, fetchgit, network
+, optparse-applicative, stdenv, text
+}:
+mkDerivation {
+ pname = "irc";
+ version = "1.0.0";
+ src = fetchgit {
+ url = "http://cgit.krebsco.de/irc";
+ sha256 = "174ywhvidybg49m4b43q2304izwbx3s7bvipk9g399zjyb392r8f";
+ rev = "7225d47e9c1f4c7032ad55fbe1d9f33ff205549c";
+ };
+ isLibrary = false;
+ isExecutable = true;
+ executableHaskellDepends = [
+ async base bytestring network optparse-applicative text
+ ];
+ license = stdenv.lib.licenses.mit;
+}