summaryrefslogtreecommitdiffstats
path: root/krebs/4lib/types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'krebs/4lib/types.nix')
-rw-r--r--krebs/4lib/types.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/krebs/4lib/types.nix b/krebs/4lib/types.nix
index 92410dd5..975c36b0 100644
--- a/krebs/4lib/types.nix
+++ b/krebs/4lib/types.nix
@@ -20,6 +20,7 @@ types // rec {
type = attrsOf net;
apply = x: assert hasAttr "retiolum" x; x;
};
+
secure = mkOption {
type = bool;
default = false;
@@ -73,6 +74,11 @@ types // rec {
}));
default = null;
};
+ zones = mkOption {
+ default = [];
+ # TODO: string is either MX, NS, A or AAAA
+ type = with types; listOf (attrsOf str);
+ };
};
});