summaryrefslogtreecommitdiffstats
path: root/3modules/tv/identity.nix
diff options
context:
space:
mode:
Diffstat (limited to '3modules/tv/identity.nix')
-rw-r--r--3modules/tv/identity.nix14
1 files changed, 9 insertions, 5 deletions
diff --git a/3modules/tv/identity.nix b/3modules/tv/identity.nix
index 0b94dff8..584b2716 100644
--- a/3modules/tv/identity.nix
+++ b/3modules/tv/identity.nix
@@ -16,15 +16,19 @@ let
type = types.host;
};
- others = mkOption {
- type = types.host;
- default = filterAttrs (name: _host: name != cfg.self.name) cfg.hosts;
- };
+ #others = mkOption {
+ # type = types.host;
+ # default = filterAttrs (name: _host: name != cfg.self.name) cfg.hosts;
+ #};
hosts = mkOption {
type = with types; attrsOf host;
apply = mapAttrs (name: value: value // { inherit name; });
};
+
+ search = mkOption {
+ type = types.hostname;
+ };
};
imp = {
@@ -36,7 +40,7 @@ let
let
aliases = toString (unique (longs ++ shorts));
longs = (splitByProvider net.aliases).hosts;
- shorts = map (removeSuffix ".${cfg.self.search}") longs;
+ shorts = map (removeSuffix ".${cfg.search}") longs;
in
map (addr: "${addr} ${aliases}") net.addrs
) host.nets