summaryrefslogtreecommitdiffstats
path: root/tv/2configs/bash.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-07-23 13:11:33 +0200
committertv <tv@krebsco.de>2016-07-23 13:11:33 +0200
commitce32d546deb0bab0fc664d65abe458fee34a5123 (patch)
treecef7811030d8662c1deed3b9b2ecd19ea96ae695 /tv/2configs/bash.nix
parent5f0e7c6dd05022ac6f0ba1dd51594070a93068ba (diff)
tv bash: init
Diffstat (limited to 'tv/2configs/bash.nix')
-rw-r--r--tv/2configs/bash.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/tv/2configs/bash.nix b/tv/2configs/bash.nix
new file mode 100644
index 00000000..fe87aa8d
--- /dev/null
+++ b/tv/2configs/bash.nix
@@ -0,0 +1,37 @@
+{ config, lib, pkgs, ... }:
+
+with config.krebs.lib;
+
+{
+ programs.bash = {
+ interactiveShellInit = ''
+ HISTCONTROL='erasedups:ignorespace'
+ HISTSIZE=65536
+ HISTFILESIZE=$HISTSIZE
+
+ shopt -s checkhash
+ shopt -s histappend histreedit histverify
+ shopt -s no_empty_cmd_completion
+ complete -d cd
+ '';
+ promptInit = ''
+ case $UID in
+ 0)
+ PS1='\[\e[1;31m\]\w\[\e[0m\] '
+ ;;
+ ${toString config.krebs.build.user.uid})
+ PS1='\[\e[1;32m\]\w\[\e[0m\] '
+ ;;
+ *)
+ PS1='\[\e[1;35m\]\u \[\e[1;32m\]\w\[\e[0m\] '
+ ;;
+ esac
+ if test -n "$SSH_CLIENT"; then
+ PS1='\[\e[35m\]\h'" $PS1"
+ fi
+ if test -n "$SSH_AGENT_PID"; then
+ PS1="ssh-agent[$SSH_AGENT_PID] $PS1"
+ fi
+ '';
+ };
+}