summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2017-09-30 16:12:08 +0200
committerlassulus <lassulus@lassul.us>2017-09-30 16:12:08 +0200
commit1a5d6a75b0f84e8bacbe24f205198918946061a7 (patch)
tree71cc0f7538a6d0b2869331000c946c7d7e8e557f /shell.nix
parent6d083f03b76f6dfbe1810f8408301d0c916c3b34 (diff)
parentbbced2ea622d97aa14f8b9bf6a75748d7d51da53 (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix17
1 files changed, 6 insertions, 11 deletions
diff --git a/shell.nix b/shell.nix
index 4b8abed5..c9b197a2 100644
--- a/shell.nix
+++ b/shell.nix
@@ -22,7 +22,12 @@ let
. ${init.env}
. ${init.proxy opts}
- exec ${utils.deploy}
+ # Use system's nixos-rebuild, which is not self-contained
+ export PATH=/run/current-system/sw/bin
+ exec ${utils.with-whatsupnix} \
+ nixos-rebuild switch \
+ --show-trace \
+ -I "$target_path"
'');
cmds.install = pkgs.withGetopt {
@@ -205,16 +210,6 @@ let
-I "$target_path" \
'';
- utils.deploy = pkgs.writeDash "utils.deploy" ''
- set -efu
- # Use system's nixos-rebuild, which is not self-contained
- export PATH=/run/current-system/sw/bin
- ${utils.with-whatsupnix} \
- nixos-rebuild switch \
- --show-trace \
- -I "$target_path"
- '';
-
utils.with-whatsupnix = pkgs.writeDash "utils.with-whatsupnix" ''
set -efu
if \test "$quiet" = true; then