summaryrefslogtreecommitdiffstats
path: root/old/modules/lass/chromium-patched.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-16 23:22:30 +0200
committertv <tv@shackspace.de>2015-07-16 23:22:30 +0200
commit57c520b722f25f384301118046bf9cf182d4edd7 (patch)
tree57983c04bb49fe0375300861111a61cede545794 /old/modules/lass/chromium-patched.nix
parent447c63edbd403abf026800d10594ed037b4304e9 (diff)
Goodbye old world, and thanks for all the fish!
Diffstat (limited to 'old/modules/lass/chromium-patched.nix')
-rw-r--r--old/modules/lass/chromium-patched.nix48
1 files changed, 0 insertions, 48 deletions
diff --git a/old/modules/lass/chromium-patched.nix b/old/modules/lass/chromium-patched.nix
deleted file mode 100644
index 71518177..00000000
--- a/old/modules/lass/chromium-patched.nix
+++ /dev/null
@@ -1,48 +0,0 @@
-{ config, pkgs, ... }:
-
-#settings to test:
-#
- #"ForceEphemeralProfiles": true,
-let
- masterPolicy = pkgs.writeText "master.json" ''
- {
- "PasswordManagerEnabled": false,
- "DefaultGeolocationSetting": 2,
- "RestoreOnStartup": 1,
- "AutoFillEnabled": false,
- "BackgroundModeEnabled": false,
- "DefaultBrowserSettingEnabled": false,
- "SafeBrowsingEnabled": false,
- "ExtensionInstallForcelist": [
- "cjpalhdlnbpafiamejdnhcphjbkeiagm;https://clients2.google.com/service/update2/crx",
- "ihlenndgcmojhcghmfjfneahoeklbjjh;https://clients2.google.com/service/update2/crx"
- ]
- }
- '';
-
- master_preferences = pkgs.writeText "master_preferences" ''
- {
- "browser": {
- "custom_chrome_frame": true
- },
-
- "extensions": {
- "theme": {
- "id": "",
- "use_system": true
- }
- }
- }
- '';
-in {
- environment.etc."chromium/policies/managed/master.json".source = pkgs.lib.mkForce masterPolicy;
-
- environment.systemPackages = [
- #pkgs.chromium
- (pkgs.lib.overrideDerivation pkgs.chromium (attrs: {
- buildCommand = attrs.buildCommand + ''
- touch $out/TEST123
- '';
- }))
- ];
-}