summaryrefslogtreecommitdiffstats
path: root/modules/cd/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-06-14 23:55:41 +0200
committertv <tv@shackspace.de>2015-06-14 23:55:41 +0200
commitdcdf12fd0bcbbc657aaae3962475747d9f3228bd (patch)
treeb010c63420be4bcf0eed571ebd101a5fd1befd45 /modules/cd/default.nix
parentcb70769a04166a7c7a0d8e92a23f9ae76f768259 (diff)
modules/tv/git: enable repo-specific hooks
Diffstat (limited to 'modules/cd/default.nix')
-rw-r--r--modules/cd/default.nix13
1 files changed, 12 insertions, 1 deletions
diff --git a/modules/cd/default.nix b/modules/cd/default.nix
index 9bb4d0f2..1d621e03 100644
--- a/modules/cd/default.nix
+++ b/modules/cd/default.nix
@@ -62,7 +62,18 @@
# TODO warn about stale repodirs
repos = addNames {
testing = {
- # TODO hooks = { post-receive = ...
+ hooks = {
+ update = ''
+ #! /bin/sh
+ set -euf
+ echo update hook: $* >&2
+ '';
+ post-update = ''
+ #! /bin/sh
+ set -euf
+ echo post-update hook: $* >&2
+ '';
+ };
};
};