summaryrefslogtreecommitdiffstats
path: root/modules/cd/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-06-22 20:11:02 +0200
committertv <tv@shackspace.de>2015-06-22 20:11:02 +0200
commit68a968ac1b1a077494efb56e18c83e79fe0bae7f (patch)
tree385aed841a2d9f7320ca35a3ce67093cb5b8470e /modules/cd/default.nix
parentf825bf5e9eb43c0c3c5858b8ca60f2c4e5d66921 (diff)
tv retiolum: split module into options and config
Diffstat (limited to 'modules/cd/default.nix')
-rw-r--r--modules/cd/default.nix24
1 files changed, 12 insertions, 12 deletions
diff --git a/modules/cd/default.nix b/modules/cd/default.nix
index 21d9565f..016f8832 100644
--- a/modules/cd/default.nix
+++ b/modules/cd/default.nix
@@ -16,7 +16,6 @@ in
../tv/ejabberd.nix # XXX echtes modul
../tv/exim-smarthost.nix
../tv/git/public.nix
- ../tv/retiolum.nix
../tv/sanitize.nix
{
imports = [ ../tv/iptables ];
@@ -34,6 +33,18 @@ in
];
};
}
+ {
+ imports = [ ../tv/retiolum ];
+ tv.retiolum = {
+ enable = true;
+ hosts = <retiolum-hosts>;
+ connectTo = [
+ "fastpoke"
+ "pigstarter"
+ "ire"
+ ];
+ };
+ }
];
# "Developer 2" plan has two vCPUs.
@@ -80,16 +91,5 @@ in
permitRootLogin = "yes";
};
- services.retiolum = {
- enable = true;
- hosts = <retiolum-hosts>;
- privateKeyFile = "/etc/tinc/retiolum/rsa_key.priv";
- connectTo = [
- "fastpoke"
- "pigstarter"
- "ire"
- ];
- };
-
sound.enable = false;
}