summaryrefslogtreecommitdiffstats
path: root/modules/cd/default.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-11 19:44:12 +0200
committertv <tv@shackspace.de>2015-07-11 19:44:12 +0200
commit2bc5c58d85990e483af8fde57ed5f2442351b69c (patch)
tree94cd29e6a98f1ce6228104055d0550e318242290 /modules/cd/default.nix
parentc5fcda1390afaba71133b2ee6ac1ddd0f559ef8c (diff)
move old stuff
Diffstat (limited to 'modules/cd/default.nix')
-rw-r--r--modules/cd/default.nix91
1 files changed, 0 insertions, 91 deletions
diff --git a/modules/cd/default.nix b/modules/cd/default.nix
deleted file mode 100644
index e3abd47e..00000000
--- a/modules/cd/default.nix
+++ /dev/null
@@ -1,91 +0,0 @@
-{ config, pkgs, ... }:
-
-let
- inherit (builtins) readFile;
-in
-
-{
- imports =
- [
- { users.extraUsers = import <secrets/extraUsers.nix>; }
- ./networking.nix
- ./users.nix
- ../tv/base.nix
- ../tv/base-cac-CentOS-7-64bit.nix
- ../tv/config/consul-server.nix
- ../tv/ejabberd.nix # XXX echtes modul
- ../tv/exim-smarthost.nix
- ../tv/git/public.nix
- ../tv/sanitize.nix
- {
- imports = [ ../tv/identity ];
- tv.identity = {
- enable = true;
- self = config.tv.identity.hosts.cd;
- };
- }
- {
- imports = [ ../tv/iptables ];
- tv.iptables = {
- enable = true;
- input-internet-accept-new-tcp = [
- "ssh"
- "tinc"
- "smtp"
- "xmpp-client"
- "xmpp-server"
- ];
- input-retiolum-accept-new-tcp = [
- "http"
- ];
- };
- }
- {
- imports = [ ../tv/retiolum ];
- tv.retiolum = {
- enable = true;
- hosts = <retiolum-hosts>;
- connectTo = [
- "fastpoke"
- "pigstarter"
- "ire"
- ];
- };
- }
- ];
-
- # "Developer 2" plan has two vCPUs.
- nix.maxJobs = 2;
-
- environment.systemPackages = with pkgs; [
- git # required for ./deploy, clone_or_update
- htop
- iftop
- iotop
- iptables
- mutt # for mv
- nethogs
- rxvt_unicode.terminfo
- tcpdump
- ];
-
- services.ejabberd-cd = {
- enable = true;
- };
-
- services.journald.extraConfig = ''
- SystemMaxUse=1G
- RuntimeMaxUse=128M
- '';
-
- services.openssh = {
- enable = true;
- hostKeys = [
- # XXX bits here make no science
- { bits = 8192; type = "ed25519"; path = "/etc/ssh/ssh_host_ed25519_key"; }
- ];
- permitRootLogin = "yes";
- };
-
- sound.enable = false;
-}