summaryrefslogtreecommitdiffstats
path: root/mb/3modules/hosts.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2019-05-10 21:02:33 +0200
committermakefu <github@syntax-fehler.de>2019-05-10 21:02:33 +0200
commit45f2d6af58967d42dc0cd6b11daacb7878b300a8 (patch)
treeeb2ea5c218c3613168226cb8bf4b095fb2aac074 /mb/3modules/hosts.nix
parentc07c0412418e3979e609fd5200a34dd1830e9334 (diff)
parent222160fc3a195415e859048bdef21f703154b3ee (diff)
Merge remote-tracking branch 'lass/master'
Diffstat (limited to 'mb/3modules/hosts.nix')
-rw-r--r--mb/3modules/hosts.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/mb/3modules/hosts.nix b/mb/3modules/hosts.nix
new file mode 100644
index 00000000..5dc9b5ca
--- /dev/null
+++ b/mb/3modules/hosts.nix
@@ -0,0 +1,12 @@
+{ config, ... }:
+
+with import <stockholm/lib>;
+
+{
+ options.mb.hosts = mkOption {
+ type = types.attrsOf types.host;
+ default =
+ filterAttrs (_: host: host.owner.name == "mb" && host.ci)
+ config.krebs.hosts;
+ };
+}