summaryrefslogtreecommitdiffstats
path: root/makefu/source.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2018-01-02 20:58:59 +0100
committertv <tv@krebsco.de>2018-01-02 20:58:59 +0100
commit493984d97e6deaee3d7b358724e83c59bccb212d (patch)
tree691e019ae0b55d48a9681d9c26ae65e6c83d1d0f /makefu/source.nix
parent84fdbeba2ceee152a128f5e9013043c172c07ecf (diff)
parente48b4eb4606f6d0ec0b930016a53e7e7cfcbfb64 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'makefu/source.nix')
-rw-r--r--makefu/source.nix18
1 files changed, 17 insertions, 1 deletions
diff --git a/makefu/source.nix b/makefu/source.nix
index ce585543..fde1d968 100644
--- a/makefu/source.nix
+++ b/makefu/source.nix
@@ -4,7 +4,9 @@ host@{ name,
secure ? false,
full ? false,
torrent ? false,
- musnix ? false
+ hw ? false,
+ musnix ? false,
+ python ? false
}:
let
builder = if getEnv "dummy_secrets" == "true"
@@ -45,6 +47,20 @@ in
ref = "d8b989f";
};
})
+
+ (mkIf ( hw ) {
+ nixos-hardware.git = {
+ url = https://github.com/nixos/nixos-hardware.git;
+ ref = "8a05dc9";
+ };
+ })
+
+ (mkIf ( python ) {
+ python.git = {
+ url = https://github.com/garbas/nixpkgs-python;
+ ref = "cac319b";
+ };
+ })
(mkIf ( torrent ) {
torrent-secrets.file = getAttr builder {
buildbot = toString <stockholm/makefu/6tests/data/secrets>;