summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/ham/deps/pykodi.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2021-02-16 22:13:39 +0100
committermakefu <github@syntax-fehler.de>2021-02-16 22:13:39 +0100
commitcacc5ca5231c85856a0974d7d6fe9cc8f5444aba (patch)
tree046ba4e3eba783683f552a0c707b036abd2e94d6 /makefu/2configs/ham/deps/pykodi.nix
parentda0ab68232757e19e1ec26e88331b88afea9e8fc (diff)
ma ham: add deps
Diffstat (limited to 'makefu/2configs/ham/deps/pykodi.nix')
-rw-r--r--makefu/2configs/ham/deps/pykodi.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/makefu/2configs/ham/deps/pykodi.nix b/makefu/2configs/ham/deps/pykodi.nix
new file mode 100644
index 00000000..85a541f8
--- /dev/null
+++ b/makefu/2configs/ham/deps/pykodi.nix
@@ -0,0 +1,37 @@
+{ lib
+, buildPythonPackage
+, fetchPypi
+, jsonrpc-async
+, jsonrpc-websocket
+, aiohttp
+}:
+
+buildPythonPackage rec {
+ pname = "pykodi";
+ version = "0.2.2";
+
+ disabled = false; # requires python version >=3.7.0
+
+ src = fetchPypi {
+ inherit pname version;
+ sha256 = "43e7036a00a76f65c34dc5e7f1065a3ef071eea7619c2e6228e521b638e640bc";
+ };
+
+ # # Package conditions to handle
+ # # might have to sed setup.py and egg.info in patchPhase
+ # # sed -i "s/<package>.../<package>/"
+ # jsonrpc-async>=1.1.0
+ # jsonrpc-websocket>=1.2.1
+ propagatedBuildInputs = [
+ jsonrpc-async
+ jsonrpc-websocket
+ aiohttp
+ ];
+
+ meta = with lib; {
+ description = "An async python interface for Kodi over JSON-RPC";
+ homepage = https://github.com/OnFreund/PyKodi;
+ license = licenses.mit;
+ # maintainers = [ maintainers. ];
+ };
+}