summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/ham/deps/pykodi.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2021-03-07 23:21:54 +0100
committerlassulus <lassulus@lassul.us>2021-03-07 23:21:54 +0100
commit6fee4ac9fef8200624e62f5e339abfae860ff497 (patch)
treeed3cb6afa03d0abc1f1072704268b9e016b487ef /makefu/2configs/ham/deps/pykodi.nix
parentae42cedf260162e4d54b39896c097fef9361f176 (diff)
parentd239a236b03fd4bbcf936bed027d9c0ef76b726f (diff)
Merge remote-tracking branch 'gum/master'
Diffstat (limited to 'makefu/2configs/ham/deps/pykodi.nix')
-rw-r--r--makefu/2configs/ham/deps/pykodi.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/makefu/2configs/ham/deps/pykodi.nix b/makefu/2configs/ham/deps/pykodi.nix
new file mode 100644
index 00000000..85a541f8
--- /dev/null
+++ b/makefu/2configs/ham/deps/pykodi.nix
@@ -0,0 +1,37 @@
+{ lib
+, buildPythonPackage
+, fetchPypi
+, jsonrpc-async
+, jsonrpc-websocket
+, aiohttp
+}:
+
+buildPythonPackage rec {
+ pname = "pykodi";
+ version = "0.2.2";
+
+ disabled = false; # requires python version >=3.7.0
+
+ src = fetchPypi {
+ inherit pname version;
+ sha256 = "43e7036a00a76f65c34dc5e7f1065a3ef071eea7619c2e6228e521b638e640bc";
+ };
+
+ # # Package conditions to handle
+ # # might have to sed setup.py and egg.info in patchPhase
+ # # sed -i "s/<package>.../<package>/"
+ # jsonrpc-async>=1.1.0
+ # jsonrpc-websocket>=1.2.1
+ propagatedBuildInputs = [
+ jsonrpc-async
+ jsonrpc-websocket
+ aiohttp
+ ];
+
+ meta = with lib; {
+ description = "An async python interface for Kodi over JSON-RPC";
+ homepage = https://github.com/OnFreund/PyKodi;
+ license = licenses.mit;
+ # maintainers = [ maintainers. ];
+ };
+}