summaryrefslogtreecommitdiffstats
path: root/makefu/2configs/Reaktor/sed-plugin.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-12-08 19:38:19 +0100
committermakefu <github@syntax-fehler.de>2015-12-08 19:38:19 +0100
commitee4546c9a4de6886f370f7ef59f327ef5f2251b1 (patch)
treec48e33e9bb07afea2560c2c5ff37666159cdcf6f /makefu/2configs/Reaktor/sed-plugin.nix
parent869a278aa8bdaf981222a4e72a4cfc3fbb740f95 (diff)
m 2 Reaktor: finish sed-plugin
Diffstat (limited to 'makefu/2configs/Reaktor/sed-plugin.nix')
-rw-r--r--makefu/2configs/Reaktor/sed-plugin.nix18
1 files changed, 18 insertions, 0 deletions
diff --git a/makefu/2configs/Reaktor/sed-plugin.nix b/makefu/2configs/Reaktor/sed-plugin.nix
new file mode 100644
index 00000000..1ec97711
--- /dev/null
+++ b/makefu/2configs/Reaktor/sed-plugin.nix
@@ -0,0 +1,18 @@
+{ config, lib, pkgs, ... }:
+
+with pkgs;
+let
+ script = ./sed-plugin.py;
+in {
+ #TODO: this will eat up the last regex, fix Reaktor
+ krebs.Reaktor.extraConfig = ''
+ public_commands.append({
+ 'capname' : "shack-correct",
+ # only support s///gi
+ 'pattern' : '^(?P<args>.*)$$',
+ 'argv' : ["${pkgs.python3}/bin/python3","${script}"],
+ 'env' : { 'state_dir' : workdir,
+ 'PATH':'${lib.makeSearchPath "bin" [pkgs.gnused]}' }})
+ '';
+}
+