summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/x/config.nix
diff options
context:
space:
mode:
authorjeschli <jeschli@gmail.com>2018-02-25 16:47:44 +0100
committerjeschli <jeschli@gmail.com>2018-02-25 16:47:44 +0100
commite5b89294d763a2ec2c289f08e4050f7776deacfd (patch)
tree75f1aff22efee3241d2967e3f5f05efd39845868 /makefu/1systems/x/config.nix
parent52b846c98b21f19c2a138361191439c487fc87cc (diff)
parent23a7012581e11e73f1dd9ceb5683c7384836a318 (diff)
Merge branch 'master' of prism.r:stockholm into staging/jeschli
Diffstat (limited to 'makefu/1systems/x/config.nix')
-rw-r--r--makefu/1systems/x/config.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/makefu/1systems/x/config.nix b/makefu/1systems/x/config.nix
index b4d4aa66..ad2ad877 100644
--- a/makefu/1systems/x/config.nix
+++ b/makefu/1systems/x/config.nix
@@ -100,7 +100,43 @@ with import <stockholm/lib>;
];
};
}
+ { # bluetooth+pulse config
+ # for blueman-applet
+ users.users.makefu.packages = [
+ pkgs.blueman
+ ];
+ hardware.pulseaudio = {
+ enable = true;
+ package = pkgs.pulseaudioFull;
+ # systemWide = true;
+ support32Bit = true;
+ configFile = pkgs.writeText "default.pa" ''
+ load-module module-udev-detect
+ load-module module-bluetooth-policy
+ load-module module-bluetooth-discover
+ load-module module-native-protocol-unix
+ load-module module-always-sink
+ load-module module-console-kit
+ load-module module-systemd-login
+ load-module module-intended-roles
+ load-module module-position-event-sounds
+ load-module module-filter-heuristics
+ load-module module-filter-apply
+ load-module module-switch-on-connect
+ '';
+ };
+ # presumably a2dp Sink
+ # Enable profile:
+ ## pacmd set-card-profile "$(pactl list cards short | egrep -o bluez_card[[:alnum:]._]+)" a2dp_sink
+ hardware.bluetooth.extraConfig = '';
+ [general]
+ Enable=Source,Sink,Media,Socket
+ '';
+
+ # connect via https://nixos.wiki/wiki/Bluetooth#Using_Bluetooth_headsets_with_PulseAudio
+ hardware.bluetooth.enable = true;
+ }
{ # auto-mounting
services.udisks2.enable = true;
services.devmon.enable = true;