summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/wry.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-09-27 20:08:36 +0200
committerlassulus <lass@aidsballs.de>2015-09-27 20:08:36 +0200
commita9f6f7ac7b8e70633164d10980d1d041f34be3ac (patch)
tree13a8bdfafd994c999c5eeae3ff5e2537a4d96f0f /makefu/1systems/wry.nix
parentb6383dba83a2e9ec6ada40fb780c15a56c8d715e (diff)
parentbc2bd6e2f6e9295b14e641b82bff62b40641988d (diff)
Merge branch 'makefu'
Diffstat (limited to 'makefu/1systems/wry.nix')
-rw-r--r--makefu/1systems/wry.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/makefu/1systems/wry.nix b/makefu/1systems/wry.nix
new file mode 100644
index 00000000..29ad82d4
--- /dev/null
+++ b/makefu/1systems/wry.nix
@@ -0,0 +1,34 @@
+{ config, lib, pkgs, ... }:
+
+let
+
+ ip = (lib.elemAt config.krebs.build.host.nets.internet.addrs4 0);
+in {
+ imports = [
+ ../../tv/2configs/CAC-CentOS-7-64bit.nix
+ ../2configs/base.nix
+ ../2configs/tinc-basic-retiolum.nix
+ {
+ }
+ ];
+ networking.firewall.allowPing = true;
+ networking.interfaces.enp2s1.ip4 = [
+ {
+ address = ip;
+ prefixLength = 24;
+ }
+ ];
+ networking.defaultGateway = "104.233.80.1";
+ networking.nameservers = [
+ "8.8.8.8"
+ ];
+
+ # based on ../../tv/2configs/CAC-Developer-2.nix
+ sound.enable = false;
+ krebs.build = {
+ user = config.krebs.users.makefu;
+ target = "root@${ip}";
+ host = config.krebs.hosts.wry;
+ };
+
+}