summaryrefslogtreecommitdiffstats
path: root/makefu/1systems/omo/hw/tsp.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2018-09-13 16:17:39 +0200
committermakefu <github@syntax-fehler.de>2018-09-13 16:17:39 +0200
commitb658de054d724064a3531de2d4a53a7a28cdc6ac (patch)
tree79d7481b6246065f5edeeb0e50288542a0603aa8 /makefu/1systems/omo/hw/tsp.nix
parent859f98583788a9324be0e8c52d36a6bb812273fe (diff)
ma omo.r: split hardware config, use disko for tsp hardware
Diffstat (limited to 'makefu/1systems/omo/hw/tsp.nix')
-rw-r--r--makefu/1systems/omo/hw/tsp.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/makefu/1systems/omo/hw/tsp.nix b/makefu/1systems/omo/hw/tsp.nix
new file mode 100644
index 00000000..4af0d73f
--- /dev/null
+++ b/makefu/1systems/omo/hw/tsp.nix
@@ -0,0 +1,32 @@
+{ pkgs, ... }:
+with builtins;
+let
+ disko = import (builtins.fetchGit {
+ url = https://cgit.lassul.us/disko/;
+ rev = "9c9b62e15e4ac11d4379e66b974f1389daf939fe";
+ });
+ cfg = fromJSON (readFile ../../hardware/tsp-disk.json);
+ primaryInterface = "enp1s0";
+ rootDisk = "/dev/sda"; # TODO same as disko uses
+in {
+ imports = [
+ (disko.config cfg)
+ ];
+ makefu.server.primary-itf = primaryInterface;
+ boot = {
+ loader.grub.device = rootDisk;
+
+ initrd.availableKernelModules = [
+ "ahci"
+ "ohci_pci"
+ "ehci_pci"
+ "pata_atiixp"
+ "firewire_ohci"
+ "usb_storage"
+ "usbhid"
+ ];
+
+ kernelModules = [ "kvm-intel" ];
+ };
+
+}