summaryrefslogtreecommitdiffstats
path: root/lib/types.nix
diff options
context:
space:
mode:
authorlassulus <lass@lassul.us>2017-04-30 18:31:11 +0200
committerlassulus <lass@lassul.us>2017-04-30 18:31:11 +0200
commitc5b1857384e220b9c12f9976e33b0c93c195a90e (patch)
tree9dd1ff1efee7c61b5772f04e4d49f67a7f5c4dc5 /lib/types.nix
parent22f019bada5fe9b688b343093a8da15be8787315 (diff)
parentca2c22601fcfc0e618bb3cc73fb6c67ac03087ea (diff)
Merge remote-tracking branch 'ni/master'
Diffstat (limited to 'lib/types.nix')
-rw-r--r--lib/types.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/lib/types.nix b/lib/types.nix
index f511541b..30de5e17 100644
--- a/lib/types.nix
+++ b/lib/types.nix
@@ -284,8 +284,8 @@ rec {
default = "/home/${config.name}";
};
mail = mkOption {
- type = str; # TODO retiolum mail address
- default = "${config._module.args.name}@${config.networking.hostName}.r";
+ type = nullOr str;
+ default = null;
};
name = mkOption {
type = username;