summaryrefslogtreecommitdiffstats
path: root/lass/2configs/xresources.nix
diff options
context:
space:
mode:
authorlassulus <lass@lassul.us>2017-02-22 21:58:13 +0100
committerlassulus <lass@lassul.us>2017-02-22 21:58:13 +0100
commit953b7f0a8e99ee5925276001d1eeacbc54cb6d36 (patch)
treef941a56a00c6d020102a75da90397684bddedef3 /lass/2configs/xresources.nix
parent8d8f26db46a739f6eb7d78a2cbd23ef8fc4e10d5 (diff)
l 2: add xresources.nix
Diffstat (limited to 'lass/2configs/xresources.nix')
-rw-r--r--lass/2configs/xresources.nix54
1 files changed, 54 insertions, 0 deletions
diff --git a/lass/2configs/xresources.nix b/lass/2configs/xresources.nix
new file mode 100644
index 00000000..58f1623b
--- /dev/null
+++ b/lass/2configs/xresources.nix
@@ -0,0 +1,54 @@
+{ config, pkgs, ... }:
+
+with import <stockholm/lib>;
+
+let
+
+ xresources = pkgs.writeText "Xresources" ''
+ URxvt*scrollBar: false
+ URxvt*urgentOnBell: true
+ URxvt*SaveLines: 4096
+ URxvt*font: -*-clean-*-*-*-*-*-*-*-*-*-*-iso10646-1
+ URxvt*boldFont: -*-clean-*-*-*-*-*-*-*-*-*-*-iso10646-1
+
+ ! ref https://github.com/muennich/urxvt-perls
+ URxvt.perl-lib: ${pkgs.urxvt_perls}/lib/urxvt/perl
+ URxvt.perl-ext-common: default,clipboard,url-select,keyboard-select
+ URxvt.url-select.launcher: ${config.lass.browser.select}/bin/browser-select
+ URxvt.url-select.underline: true
+ URxvt.keysym.M-u: perl:url-select:select_next
+ URxvt.keysym.M-Escape: perl:keyboard-select:activate
+ URxvt.keysym.M-s: perl:keyboard-select:search
+
+ URxvt.intensityStyles: false
+
+ URxvt*background: #000000
+ URxvt*foreground: #d0d7d0
+
+ URxvt*cursorColor: #f042b0
+ URxvt*cursorColor2: #f0b000
+ URxvt*cursorBlink: off
+
+ URxvt*.pointerBlank: true
+ URxvt*.pointerBlankDelay: 987654321
+ URxvt*.pointerColor: #f042b0
+ URxvt*.pointerColor2: #050505
+ '';
+
+in {
+ systemd.user.services.xresources = {
+ description = "xresources";
+ wantedBy = [ "default.target" ];
+
+ environment = {
+ DISPLAY = ":0";
+ };
+
+ restartIfChanged = true;
+
+ serviceConfig = {
+ Type = "simple";
+ ExecStart = "${pkgs.xorg.xrdb}/bin/xrdb -merge ${xresources}";
+ };
+ };
+}