summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/simple/htgen-paste/default.nix
diff options
context:
space:
mode:
authorlassulus <git@lassul.us>2023-04-28 23:11:21 +0200
committerlassulus <git@lassul.us>2023-04-28 23:48:38 +0200
commitd3b150416989aae2fa4aebf097dac96d53cd2164 (patch)
treec4520f6e9f5da5c51af729c0093ce97903fb2d88 /krebs/5pkgs/simple/htgen-paste/default.nix
parent67a2ab17a6b06527a31b03770615d5f64c18cded (diff)
vendor htgen-paste
Diffstat (limited to 'krebs/5pkgs/simple/htgen-paste/default.nix')
-rw-r--r--krebs/5pkgs/simple/htgen-paste/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/krebs/5pkgs/simple/htgen-paste/default.nix b/krebs/5pkgs/simple/htgen-paste/default.nix
new file mode 100644
index 00000000..48b72833
--- /dev/null
+++ b/krebs/5pkgs/simple/htgen-paste/default.nix
@@ -0,0 +1,27 @@
+{ pkgs, stockholm, stdenv }:
+with stockholm.lib;
+
+stdenv.mkDerivation rec {
+ pname = "htgen-paste";
+ version = "1.0.0";
+
+ src = ./src;
+
+ buildPhase = ''
+ (
+ exec > htgen-paste
+ echo PATH=${makeBinPath [
+ pkgs.nix
+ pkgs.file
+ pkgs.coreutils
+ pkgs.findutils
+ ]}
+ echo STATEDIR=${shell.escape "\${STATEDIR-$HOME}"}
+ cat $src/htgen-paste
+ )
+ '';
+
+ installPhase = ''
+ install -D htgen-paste $out/bin/htgen-paste
+ '';
+}