summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/posix-array/default.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-09-05 12:17:59 +0200
committerlassulus <lass@aidsballs.de>2015-09-05 12:17:59 +0200
commitf54a0a9ea7fd5a9902a5b38786da42f06d615b5a (patch)
treed7c475b212d8acc35a5dc7d20ec1f2228c664010 /krebs/5pkgs/posix-array/default.nix
parentf3c1727659c59ff638b1adead8e30ee2f79f39de (diff)
parentd6d9956abc60548c755d30e6a5bd13c10abbb181 (diff)
Merge branch 'makefu'
Diffstat (limited to 'krebs/5pkgs/posix-array/default.nix')
-rw-r--r--krebs/5pkgs/posix-array/default.nix31
1 files changed, 31 insertions, 0 deletions
diff --git a/krebs/5pkgs/posix-array/default.nix b/krebs/5pkgs/posix-array/default.nix
new file mode 100644
index 00000000..456a3cc1
--- /dev/null
+++ b/krebs/5pkgs/posix-array/default.nix
@@ -0,0 +1,31 @@
+{ stdenv, fetchgit, ... }:
+
+with stdenv; stdenv.mkDerivation rec {
+ name = "posix-array";
+ version = "1.0.0";
+
+ src = fetchgit {
+ url = https://github.com/makefu/array.git;
+ rev = "refs/tags/${version}";
+ sha256 = "0yzwlhdg1rgc4p64ny7gj30l7z6vikhskhppsa2qj7s9gm2gz938";
+ };
+
+ phases = [
+ "unpackPhase"
+ "installPhase"
+ ];
+
+ installPhase = ''
+ mkdir -p "$out/bin"
+ cp -a ./array $out/bin
+ rm *
+ '';
+
+ meta = {
+ description = "Posix-compliant array implementation";
+ url = https://github.com/makefu/array;
+ license = licenses.wtfpl;
+ platforms = platforms.unix;
+ maintainers = with maintainers; [ makefu ];
+ };
+}