summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/much/default.nix
diff options
context:
space:
mode:
authorlassulus <lass@aidsballs.de>2015-09-05 12:17:59 +0200
committerlassulus <lass@aidsballs.de>2015-09-05 12:17:59 +0200
commitf54a0a9ea7fd5a9902a5b38786da42f06d615b5a (patch)
treed7c475b212d8acc35a5dc7d20ec1f2228c664010 /krebs/5pkgs/much/default.nix
parentf3c1727659c59ff638b1adead8e30ee2f79f39de (diff)
parentd6d9956abc60548c755d30e6a5bd13c10abbb181 (diff)
Merge branch 'makefu'
Diffstat (limited to 'krebs/5pkgs/much/default.nix')
-rw-r--r--krebs/5pkgs/much/default.nix64
1 files changed, 64 insertions, 0 deletions
diff --git a/krebs/5pkgs/much/default.nix b/krebs/5pkgs/much/default.nix
new file mode 100644
index 00000000..82586b42
--- /dev/null
+++ b/krebs/5pkgs/much/default.nix
@@ -0,0 +1,64 @@
+{ pkgs, ... }:
+
+let
+ hspkgs = pkgs.haskellngPackages.override {
+ overrides = self: super: {
+ email-header = self.callPackage (
+{ mkDerivation, attoparsec, base, base64-bytestring, bytestring
+, case-insensitive, containers, exceptions, fetchgit, QuickCheck
+, stdenv, tasty, tasty-quickcheck, text, text-icu, time
+}:
+mkDerivation {
+ pname = "email-header";
+ version = "0.3.0";
+ src = fetchgit {
+ url = "https://github.com/4z3/email-header";
+ sha256 = "f33fba567a39b1f2448869b269c26c40d8007599c23ab83bde5b4dfd9fd76ebc";
+ rev = "7b179bd31192ead8afe7a0b6e34bcad4039deaa8";
+ };
+ buildDepends = [
+ attoparsec base base64-bytestring bytestring case-insensitive
+ containers exceptions text text-icu time
+ ];
+ testDepends = [
+ base bytestring case-insensitive containers QuickCheck tasty
+ tasty-quickcheck text time
+ ];
+ jailbreak = true;
+ homepage = "http://github.com/knrafto/email-header";
+ description = "Parsing and rendering of email and MIME headers";
+ license = stdenv.lib.licenses.bsd3;
+}
+) {};
+ };
+ };
+in
+
+hspkgs.callPackage (
+{ mkDerivation, aeson, attoparsec, base, base64-bytestring
+, blaze-builder, bytestring, case-insensitive, containers, deepseq
+, directory, docopt, email-header, fetchgit, filepath
+, friendly-time, hyphenation, linebreak, old-locale, process
+, random, rosezipper, safe, split, stdenv, terminal-size, text
+, time, transformers, transformers-compat, unix, vector
+}:
+mkDerivation {
+ pname = "much";
+ version = "0.0.0.0";
+ src = fetchgit {
+ url = "http://cgit.nomic/much";
+ sha256 = "f0bcc34456cb876d3439694d1e16db414a540e13f476fa3ff1ad70d1d3caccb2";
+ rev = "bfd854e05207a073eaa983c49f27c37555ccfce5";
+ };
+ isLibrary = false;
+ isExecutable = true;
+ buildDepends = [
+ aeson attoparsec base base64-bytestring blaze-builder bytestring
+ case-insensitive containers deepseq directory docopt email-header
+ filepath friendly-time hyphenation linebreak old-locale process
+ random rosezipper safe split terminal-size text time transformers
+ transformers-compat unix vector
+ ];
+ license = stdenv.lib.licenses.mit;
+}
+) {}