summaryrefslogtreecommitdiffstats
path: root/krebs/5pkgs/builders.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-05-21 11:18:24 +0200
committertv <tv@krebsco.de>2016-05-21 11:19:35 +0200
commit97c2e4bbd99f6034d550a83804e508c278045b67 (patch)
treeed90854259a9f54a7c46e8168187d29419eb9203 /krebs/5pkgs/builders.nix
parentace70674aa9fc4580816225223934b6d7edd9204 (diff)
krebs.exim: validate config file syntax
Diffstat (limited to 'krebs/5pkgs/builders.nix')
-rw-r--r--krebs/5pkgs/builders.nix8
1 files changed, 8 insertions, 0 deletions
diff --git a/krebs/5pkgs/builders.nix b/krebs/5pkgs/builders.nix
index 146e6f9e..70d65cfc 100644
--- a/krebs/5pkgs/builders.nix
+++ b/krebs/5pkgs/builders.nix
@@ -56,6 +56,14 @@ rec {
'';
};
+ writeEximConfig = name: text: pkgs.runCommand name {
+ inherit text;
+ passAsFile = [ "text" ];
+ } ''
+ ${pkgs.exim}/bin/exim -C "$textPath" -bV >/dev/null
+ mv "$textPath" $out
+ '';
+
writeNixFromCabal = name: path: pkgs.runCommand name {} ''
${pkgs.cabal2nix}/bin/cabal2nix ${path} > $out
'';