summaryrefslogtreecommitdiffstats
path: root/krebs/4lib/types.nix
diff options
context:
space:
mode:
authortv <tv@krebsco.de>2016-02-21 06:56:57 +0100
committertv <tv@krebsco.de>2016-02-21 06:56:57 +0100
commit05be525be6d0896b155da7305b2cee950fb3530e (patch)
tree0c9c431b3ffd853e334a070e69fa4b54ae9114b9 /krebs/4lib/types.nix
parentc5f18dfdfe9874ba48834447c8d3259b115c1357 (diff)
krebs.types.user: add uid :: int
Diffstat (limited to 'krebs/4lib/types.nix')
-rw-r--r--krebs/4lib/types.nix4
1 files changed, 4 insertions, 0 deletions
diff --git a/krebs/4lib/types.nix b/krebs/4lib/types.nix
index 41af1cd4..42262729 100644
--- a/krebs/4lib/types.nix
+++ b/krebs/4lib/types.nix
@@ -179,6 +179,10 @@ types // rec {
pubkey = mkOption {
type = str;
};
+ uid = mkOption {
+ type = int;
+ default = genid config.name;
+ };
};
});