summaryrefslogtreecommitdiffstats
path: root/jeschli/1systems/bolide/hardware-configuration.nix
diff options
context:
space:
mode:
authornin <nin@c-base.org>2018-01-30 23:06:17 +0100
committernin <nin@c-base.org>2018-01-30 23:06:17 +0100
commit6849d7aa4810d5f1f2ec55d852d21812dd1b8002 (patch)
treeb2b236981d6cb2d226fbe239845838a15c22b30e /jeschli/1systems/bolide/hardware-configuration.nix
parent80c2e23ec028bfda5c0bad0e3269648d34d298b0 (diff)
parentffc294575cb59585c3bfb6b85fa45fb69cdf1d41 (diff)
Merge remote-tracking branch 'prism/master'
Diffstat (limited to 'jeschli/1systems/bolide/hardware-configuration.nix')
-rw-r--r--jeschli/1systems/bolide/hardware-configuration.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/jeschli/1systems/bolide/hardware-configuration.nix b/jeschli/1systems/bolide/hardware-configuration.nix
new file mode 100644
index 00000000..183b29e4
--- /dev/null
+++ b/jeschli/1systems/bolide/hardware-configuration.nix
@@ -0,0 +1,32 @@
+# Do not modify this file! It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations. Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, ... }:
+
+{
+ imports =
+ [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+ ];
+
+ boot.initrd.availableKernelModules = [ "xhci_pci" "ahci" "usb_storage" "usbhid" "sd_mod" ];
+ boot.kernelModules = [ "kvm-intel" "wl" ];
+ boot.extraModulePackages = [ config.boot.kernelPackages.broadcom_sta ];
+
+ fileSystems."/" =
+ { device = "/dev/bolide-pool/bolide-root";
+ fsType = "ext4";
+ };
+
+ fileSystems."/home" =
+ { device = "/dev/bolide-pool/bolide-home";
+ fsType = "ext4";
+ };
+ fileSystems."/boot" =
+ { device = "/dev/disk/by-uuid/3aeb67c4-5b6e-4df2-8013-607fe0fb8525";
+ fsType = "ext4";
+ };
+ swapDevices = [ ];
+
+ nix.maxJobs = lib.mkDefault 8;
+ powerManagement.cpuFreqGovernor = "powersave";
+}