summaryrefslogtreecommitdiffstats
path: root/Zpkgs/krebs/dic.nix
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2015-07-24 23:57:12 +0200
committermakefu <github@syntax-fehler.de>2015-07-24 23:57:12 +0200
commitf338d3d4d15ff29b3048b4f89716a8aa1a19f21b (patch)
treebb803bdcc4d93141e16e94e417c69ca8b1b3c9f5 /Zpkgs/krebs/dic.nix
parenta4d2509918c3ce1400071eb0ef2b5421023976ca (diff)
parent99527e88aec089b4fea496248cf03f738bfed257 (diff)
Merge remote-tracking branch 'cd/master'
Diffstat (limited to 'Zpkgs/krebs/dic.nix')
-rw-r--r--Zpkgs/krebs/dic.nix36
1 files changed, 36 insertions, 0 deletions
diff --git a/Zpkgs/krebs/dic.nix b/Zpkgs/krebs/dic.nix
new file mode 100644
index 00000000..571773d2
--- /dev/null
+++ b/Zpkgs/krebs/dic.nix
@@ -0,0 +1,36 @@
+{ stdenv, fetchgit, coreutils, curl, gnused, gnugrep, ... }:
+
+stdenv.mkDerivation {
+ name = "dic";
+
+ src = fetchgit {
+ url = https://github.com/krebscode/painload;
+ rev = "35ccac73d563ad30d2851b9aeed4cfef69ff74e3";
+ sha256 = "1y1fs2p3xj2yrqpw0h5kd0f3c5p1y70xk1hjnw99sr33r67s9c35";
+ };
+
+ phases = [
+ "unpackPhase"
+ "installPhase"
+ ];
+
+ installPhase =
+ let
+ path = stdenv.lib.makeSearchPath "bin" [
+ coreutils
+ curl
+ gnused
+ gnugrep
+ ];
+ in
+ ''
+ mkdir -p $out/bin
+
+ sed \
+ 's,^main() {$,&\n PATH=${path}; export PATH,' \
+ < ./util/bin/dic \
+ > $out/bin/dic
+
+ chmod +x $out/bin/dic
+ '';
+}