summaryrefslogtreecommitdiffstats
path: root/3modules/krebs/git.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-24 20:48:00 +0200
committertv <tv@shackspace.de>2015-07-24 20:49:46 +0200
commita62be1cef8726a2afa61df3dac9e19a71882b370 (patch)
tree9415cfbe7628cbcce03d1691ea02e71be7babc88 /3modules/krebs/git.nix
parent54becaa19fcbc11ac709ddaf86e56ee3b736931d (diff)
{2 tv git -> 3 krebs}.users
Diffstat (limited to '3modules/krebs/git.nix')
-rw-r--r--3modules/krebs/git.nix11
1 files changed, 4 insertions, 7 deletions
diff --git a/3modules/krebs/git.nix b/3modules/krebs/git.nix
index 3c3e9342..be6619b4 100644
--- a/3modules/krebs/git.nix
+++ b/3modules/krebs/git.nix
@@ -6,8 +6,7 @@
# TODO when authorized_keys changes, then restart ssh
# (or kill already connected users somehow)
-with builtins;
-with lib;
+with import ../../4lib/krebs { inherit lib; };
let
cfg = config.krebs.git;
@@ -119,9 +118,6 @@ let
rules = mkOption {
type = types.unspecified;
};
- users = mkOption {
- type = types.unspecified;
- };
};
git-imp = {
@@ -149,7 +145,8 @@ let
name = "git";
shell = "/bin/sh";
openssh.authorizedKeys.keys =
- mapAttrsToList (_: makeAuthorizedKey git-ssh-command) cfg.users;
+ mapAttrsToList (_: makeAuthorizedKey git-ssh-command)
+ config.krebs.users;
uid = 129318403; # genid git
};
};
@@ -255,7 +252,7 @@ let
isPublicRepo = getAttr "public"; # TODO this is also in ./cgit.nix
- makeAuthorizedKey = git-ssh-command: user@{ name, pubkey }:
+ makeAuthorizedKey = git-ssh-command: user@{ name, pubkey, ... }:
# TODO assert name
# TODO assert pubkey
let