summaryrefslogtreecommitdiffstats
path: root/2configs/tv/git-public.nix
diff options
context:
space:
mode:
authortv <tv@shackspace.de>2015-07-24 19:33:20 +0200
committertv <tv@shackspace.de>2015-07-24 19:33:20 +0200
commit54becaa19fcbc11ac709ddaf86e56ee3b736931d (patch)
tree28357f0dd122e02a96424c0707c35cdc2177ca3a /2configs/tv/git-public.nix
parentf4309272e2531a136a40d2332d1bfecec16d9a91 (diff)
tv git: add restricted repos
Diffstat (limited to '2configs/tv/git-public.nix')
-rw-r--r--2configs/tv/git-public.nix79
1 files changed, 0 insertions, 79 deletions
diff --git a/2configs/tv/git-public.nix b/2configs/tv/git-public.nix
deleted file mode 100644
index 1bf44e0f..00000000
--- a/2configs/tv/git-public.nix
+++ /dev/null
@@ -1,79 +0,0 @@
-{ config, lib, pkgs, ... }:
-with import ../../4lib/tv { inherit lib pkgs; };
-let
-
- out = {
- krebs.git = {
- enable = true;
- root-title = "public repositories at ${config.tv.identity.self.name}";
- root-desc = "keep calm and engage";
- inherit repos rules users;
- };
- };
-
- repos = public-repos;
- rules = concatMap make-rules (attrValues repos);
-
- public-repos = mapAttrs make-public-repo {
- cgserver = {};
- crude-mail-setup = {};
- dot-xmonad = {};
- hack = {};
- load-env = {};
- make-snapshot = {};
- mime = {};
- much = {};
- nixos-infest = {};
- nixpkgs = {};
- painload = {};
- quipper = {};
- regfish = {};
- stockholm = {
- desc = "take all the computers hostage, they'll love you!";
- };
- wai-middleware-time = {};
- web-routes-wai-custom = {};
- xintmap = {};
- };
-
- # TODO move users to separate module
- users = mapAttrs make-user {
- tv = ../../Zpubkeys/tv_wu.ssh.pub;
- lass = ../../Zpubkeys/lass.ssh.pub;
- uriel = ../../Zpubkeys/uriel.ssh.pub;
- makefu = ../../Zpubkeys/makefu.ssh.pub;
- };
-
- make-public-repo = name: { desc ? null, ... }: {
- inherit name desc;
- public = true;
- hooks = {
- post-receive = git.irc-announce {
- # TODO make nick = config.tv.identity.self.name the default
- nick = config.tv.identity.self.name;
- channel = "#retiolum";
- server = "cd.retiolum";
- };
- };
- };
-
- make-rules =
- with git // users;
- repo:
- singleton {
- user = tv;
- repo = [ repo ];
- perm = push "refs/*" [ non-fast-forward create delete merge ];
- } ++
- optional repo.public {
- user = [ lass makefu uriel ];
- repo = [ repo ];
- perm = fetch;
- };
-
- make-user = name: pubkey-file: {
- inherit name;
- pubkey = readFile pubkey-file;
- };
-
-in out