summaryrefslogtreecommitdiffstats
path: root/types.nix
diff options
context:
space:
mode:
Diffstat (limited to 'types.nix')
-rw-r--r--types.nix4
1 files changed, 1 insertions, 3 deletions
diff --git a/types.nix b/types.nix
index db70ede..6c35de6 100644
--- a/types.nix
+++ b/types.nix
@@ -156,9 +156,7 @@ rec {
config :: types.devices -> nixosConfig
*/
- config = devices: {
- imports = flatten (map (dev: dev._config) (flatten (map attrValues (attrValues devices))));
- };
+ config = devices: flatten (map (dev: dev._config) (flatten (map attrValues (attrValues devices))));
/* Takes a disko device specification and returns a function to get the needed packages to format/mount the disks
packages :: types.devices -> pkgs -> [ derivation ]