summaryrefslogtreecommitdiffstats
path: root/tests/negative-size.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tests/negative-size.nix')
-rw-r--r--tests/negative-size.nix11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/negative-size.nix b/tests/negative-size.nix
new file mode 100644
index 0000000..224b00c
--- /dev/null
+++ b/tests/negative-size.nix
@@ -0,0 +1,11 @@
+# this is a regression test for https://github.com/nix-community/disko/issues/52
+{ pkgs ? (import <nixpkgs> { })
+, makeDiskoTest ? (pkgs.callPackage ./lib.nix { }).makeDiskoTest
+}:
+makeDiskoTest {
+ disko-config = ../example/negative-size.nix;
+ testBoot = false;
+ extraTestScript = ''
+ machine.succeed("mountpoint /mnt");
+ '';
+}