summaryrefslogtreecommitdiffstats
path: root/package.nix
diff options
context:
space:
mode:
Diffstat (limited to 'package.nix')
-rw-r--r--package.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/package.nix b/package.nix
new file mode 100644
index 0000000..6e63310
--- /dev/null
+++ b/package.nix
@@ -0,0 +1,34 @@
+{ stdenvNoCC, lib }:
+
+let
+ inclFiles = {src, name}: files: lib.cleanSourceWith {
+ inherit src name;
+ filter = _path: _type: _type == "regular" && lib.any (file: builtins.baseNameOf _path == file) files;
+ };
+in
+stdenvNoCC.mkDerivation rec {
+ name = "disko";
+ src = inclFiles { inherit name; src = ./.; } [
+ "disko"
+ "cli.nix"
+ "default.nix"
+ "types.nix"
+ "options.nix"
+ ];
+ installPhase = ''
+ mkdir -p $out/bin $out/share/disko
+ cp -r $src/* $out/share/disko
+ sed \
+ -e "s|libexec_dir=\".*\"|libexec_dir=\"$out/share/disko\"|" \
+ -e "s|#!/usr/bin/env.*|#!/usr/bin/env bash|" \
+ $src/disko > $out/bin/disko
+ chmod 755 $out/bin/disko
+ '';
+ meta = with lib; {
+ description = "Format disks with nix-config";
+ homepage = "https://github.com/nix-community/disko";
+ license = licenses.mit;
+ maintainers = with maintainers; [ lassulus ];
+ platforms = platforms.linux;
+ };
+}