summaryrefslogtreecommitdiffstats
path: root/lib/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'lib/default.nix')
-rw-r--r--lib/default.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/lib/default.nix b/lib/default.nix
index ec8e4bf..7793acf 100644
--- a/lib/default.nix
+++ b/lib/default.nix
@@ -31,6 +31,8 @@ let {
config.lvm = q: x:
foldl' recursiveUpdate {} (mapAttrsToList (name: config-f { inherit name; vgname = x.name; }) x.lvs);
+ config.noop = q: x: {};
+
config.partition = q: x:
config-f { device = q.device + toString q.index; } x.content;
@@ -65,6 +67,8 @@ let {
${concatStrings (mapAttrsToList (name: create-f { inherit name; vgname = x.name; }) x.lvs)}
'';
+ create.noop = q: x: "";
+
create.partition = q: x: ''
parted -s ${q.device} mkpart ${x.part-type} ${x.fs-type or ""} ${x.start} ${x.end}
${optionalString (x.bootable or false) ''
@@ -119,6 +123,8 @@ let {
'';}
);
+ mount.noop = q: x: {};
+
mount.partition = q: x:
mount-f { device = q.device + toString q.index; } x.content;