summaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix5
1 files changed, 3 insertions, 2 deletions
diff --git a/flake.nix b/flake.nix
index cd955a2..dd065cf 100644
--- a/flake.nix
+++ b/flake.nix
@@ -1,7 +1,8 @@
{
description = "Description for the project";
- inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixos-unstable";
+ # don't lock to give precedence to a USB live-installer's registry
+ inputs.nixpkgs.url = "nixpkgs";
outputs = { self, nixpkgs, ... }: {
nixosModules.disko = import ./module.nix;
@@ -9,8 +10,8 @@
inherit (nixpkgs) lib;
};
packages.x86_64-linux.disko = let
- inherit (nixpkgs) lib;
pkgs = nixpkgs.legacyPackages.x86_64-linux;
+ inherit (pkgs) lib;
inclFiles = {src, name}: files: lib.cleanSourceWith {
inherit src name;
filter = _path: _type: _type == "regular"