summaryrefslogtreecommitdiffstats
path: root/example/zfs-over-legacy.nix
diff options
context:
space:
mode:
Diffstat (limited to 'example/zfs-over-legacy.nix')
-rw-r--r--example/zfs-over-legacy.nix66
1 files changed, 66 insertions, 0 deletions
diff --git a/example/zfs-over-legacy.nix b/example/zfs-over-legacy.nix
new file mode 100644
index 0000000..1a6bbd3
--- /dev/null
+++ b/example/zfs-over-legacy.nix
@@ -0,0 +1,66 @@
+{ disks ? [ "/dev/vdb" "/dev/vdc" ], ... }: {
+ disk = {
+ vdb = {
+ type = "disk";
+ device = builtins.elemAt disks 0;
+ content = {
+ type = "table";
+ format = "gpt";
+ partitions = [
+ {
+ type = "partition";
+ name = "ESP";
+ start = "1MiB";
+ end = "100MiB";
+ bootable = true;
+ content = {
+ type = "filesystem";
+ format = "vfat";
+ mountpoint = "/boot";
+ mountOptions = [
+ "defaults"
+ ];
+ };
+ }
+ {
+ type = "partition";
+ start = "100MiB";
+ end = "100%";
+ name = "primary";
+ bootable = true;
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/";
+ };
+ }
+ ];
+ };
+ };
+ vdc = {
+ type = "disk";
+ device = builtins.elemAt disks 1;
+ content = {
+ type = "zfs";
+ pool = "zroot";
+ };
+ };
+ };
+ zpool = {
+ zroot = {
+ type = "zpool";
+ datasets = {
+ "root" = {
+ zfs_type = "filesystem";
+ options.mountpoint = "none";
+ };
+ "root/zfs_fs" = {
+ zfs_type = "filesystem";
+ mountpoint = "/zfs_fs";
+ options."com.sun:auto-snapshot" = "true";
+ };
+ };
+ };
+ };
+}
+