summaryrefslogtreecommitdiffstats
path: root/example/with-lib.nix
diff options
context:
space:
mode:
Diffstat (limited to 'example/with-lib.nix')
-rw-r--r--example/with-lib.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/example/with-lib.nix b/example/with-lib.nix
new file mode 100644
index 0000000..ce0b93d
--- /dev/null
+++ b/example/with-lib.nix
@@ -0,0 +1,35 @@
+# Example to create a bios compatible gpt partition
+{ disks ? [ "/dev/vdb" ], lib, ... }: {
+ disk = lib.genAttrs [ (lib.head disks) ] (device: {
+ device = device;
+ type = "disk";
+ content = {
+ type = "table";
+ format = "gpt";
+ partitions = [
+ {
+ name = "boot";
+ type = "partition";
+ start = "0";
+ end = "1M";
+ part-type = "primary";
+ flags = ["bios_grub"];
+ }
+ {
+ name = "root";
+ type = "partition";
+ # leave space for the grub aka BIOS boot
+ start = "1M";
+ end = "100%";
+ part-type = "primary";
+ bootable = true;
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/";
+ };
+ }
+ ];
+ };
+ });
+}