summaryrefslogtreecommitdiffstats
path: root/example/swap.nix
diff options
context:
space:
mode:
Diffstat (limited to 'example/swap.nix')
-rw-r--r--example/swap.nix50
1 files changed, 50 insertions, 0 deletions
diff --git a/example/swap.nix b/example/swap.nix
new file mode 100644
index 0000000..13393fe
--- /dev/null
+++ b/example/swap.nix
@@ -0,0 +1,50 @@
+{ disks ? [ "/dev/vdb" ], ... }: {
+ disk = {
+ vdb = {
+ device = builtins.elemAt disks 0;
+ type = "disk";
+ content = {
+ type = "table";
+ format = "gpt";
+ partitions = [
+ {
+ type = "partition";
+ name = "ESP";
+ start = "1MiB";
+ end = "100MiB";
+ bootable = true;
+ content = {
+ type = "filesystem";
+ format = "vfat";
+ mountpoint = "/boot";
+ };
+ }
+ {
+ name = "root";
+ type = "partition";
+ start = "100MiB";
+ end = "-1G";
+ part-type = "primary";
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/";
+ };
+ }
+ {
+ name = "swap";
+ type = "partition";
+ start = "-1G";
+ end = "100%";
+ part-type = "primary";
+ content = {
+ type = "swap";
+ randomEncryption = true;
+ };
+ }
+ ];
+ };
+ };
+ };
+}
+