summaryrefslogtreecommitdiffstats
path: root/types.nix
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2022-11-25 12:52:40 +0100
committerlassulus <lassulus@lassul.us>2022-11-25 17:36:40 +0100
commit6bbdafce48bbd8a076e7f27bff17ea8fe6f531d4 (patch)
treebca74ed2cce440c937666de9938b646427afe64b /types.nix
parent7a4c85b53e151f8a189a88336adbadc9305b4873 (diff)
zapCreateMount: stop mdraids
Diffstat (limited to 'types.nix')
-rw-r--r--types.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/types.nix b/types.nix
index 92f11fb..2ed3ccc 100644
--- a/types.nix
+++ b/types.nix
@@ -152,6 +152,7 @@ rec {
*/
zapCreateMount = devices: ''
set -efux
+ shopt -s nullglob
# print existing disks
lsblk
@@ -161,6 +162,12 @@ rec {
umount -Rlv /mnt
fi
+ # stop all existing raids
+ for r in /dev/md/* /dev/md[0-9]*; do
+ # might fail if the device was already closed in the loop
+ mdadm --stop "$r" || true
+ done
+
echo 'creating partitions...'
${diskoLib.create devices}
echo 'mounting partitions...'