summaryrefslogtreecommitdiffstats
path: root/example/zfs.nix
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2022-08-26 14:59:28 +0100
committerGitHub <noreply@github.com>2022-08-26 14:59:28 +0100
commitadf901d58155ca268d15351fff164d3ef38a0890 (patch)
treec6057a3d362e06742073b35d4c11db7ee9a0a820 /example/zfs.nix
parent6b0b20da18cdffd09f04faee7128c557bcb9f054 (diff)
parent9bb4aec9640cbc30e241c267158e506278862b5e (diff)
Merge pull request #27 from nix-community/zfs
zfs, lvm raid, btrfs subvolumes support & some fixups
Diffstat (limited to 'example/zfs.nix')
-rw-r--r--example/zfs.nix53
1 files changed, 53 insertions, 0 deletions
diff --git a/example/zfs.nix b/example/zfs.nix
new file mode 100644
index 0000000..60e4700
--- /dev/null
+++ b/example/zfs.nix
@@ -0,0 +1,53 @@
+{
+ type = "devices";
+ content = {
+ vdb = {
+ type = "zfs";
+ pool = "zroot";
+ };
+ vdc = {
+ type = "zfs";
+ pool = "zroot";
+ };
+ zroot = {
+ type = "zpool";
+ mode = "mirror";
+ rootFsOptions = {
+ compression = "lz4";
+ "com.sun:auto-snapshot" = "false";
+ };
+ mountpoint = "/";
+
+ datasets = [
+ {
+ type = "zfs_filesystem";
+ name = "zfs_fs";
+ mountpoint = "/zfs_fs";
+ options."com.sun:auto-snapshot" = "true";
+ }
+ {
+ type = "zfs_filesystem";
+ name = "zfs_unmounted_fs";
+ options.mountpoint = "none";
+ }
+ {
+ type = "zfs_filesystem";
+ name = "zfs_legacy_fs";
+ options.mountpoint = "legacy";
+ mountpoint = "/zfs_legacy_fs";
+ }
+ {
+ type = "zfs_volume";
+ name = "zfs_testvolume";
+ size = "10M";
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/ext4onzfs";
+ };
+ }
+ ];
+ };
+ };
+}
+