summaryrefslogtreecommitdiffstats
path: root/example/mdadm.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2022-08-25 13:13:20 +0200
committerlassulus <lassulus@lassul.us>2022-08-25 15:32:09 +0200
commit1237ac36db1a457ae561134d191d2924a9ce5ffc (patch)
tree893e0455554e2a98244b8a7f94363b11007f0b59 /example/mdadm.nix
parent6b0b20da18cdffd09f04faee7128c557bcb9f054 (diff)
fix mdadm mounting, move test to mdadm test
Diffstat (limited to 'example/mdadm.nix')
-rw-r--r--example/mdadm.nix59
1 files changed, 59 insertions, 0 deletions
diff --git a/example/mdadm.nix b/example/mdadm.nix
new file mode 100644
index 0000000..cb0ad91
--- /dev/null
+++ b/example/mdadm.nix
@@ -0,0 +1,59 @@
+# usage: nix-instantiate --eval --json --strict example/config.nix | jq .
+{
+ type = "devices";
+ content = {
+ vdb = {
+ type = "table";
+ format = "gpt";
+ partitions = [
+ {
+ type = "partition";
+ part-type = "primary";
+ start = "1MiB";
+ end = "100%";
+ content = {
+ type = "mdraid";
+ name = "raid1";
+ };
+ }
+ ];
+ };
+ vdc = {
+ type = "table";
+ format = "gpt";
+ partitions = [
+ {
+ type = "partition";
+ part-type = "primary";
+ start = "1MiB";
+ end = "100%";
+ content = {
+ type = "mdraid";
+ name = "raid1";
+ };
+ }
+ ];
+ };
+ raid1 = {
+ type = "mdadm";
+ level = 1;
+ content = {
+ type = "table";
+ format = "gpt";
+ partitions = [
+ {
+ type = "partition";
+ part-type = "primary";
+ start = "1MiB";
+ end = "100%";
+ content = {
+ type = "filesystem";
+ format = "ext4";
+ mountpoint = "/raid";
+ };
+ }
+ ];
+ };
+ };
+ };
+}