summaryrefslogtreecommitdiffstats
path: root/example/btrfs-subvolumes.nix
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2022-09-04 12:11:54 +0100
committerGitHub <noreply@github.com>2022-09-04 12:11:54 +0100
commitfbc08430d28a65eb3e783feb892659d32abd4551 (patch)
treecba2f7972cb82ff445e68383a46927c8a25ec763 /example/btrfs-subvolumes.nix
parentadf901d58155ca268d15351fff164d3ef38a0890 (diff)
parent68f950bf2045573b03cd0e1ceebe7131ea999873 (diff)
Merge pull request #31 from nix-community/types
Reimplement using types
Diffstat (limited to 'example/btrfs-subvolumes.nix')
-rw-r--r--example/btrfs-subvolumes.nix43
1 files changed, 23 insertions, 20 deletions
diff --git a/example/btrfs-subvolumes.nix b/example/btrfs-subvolumes.nix
index 0124c86..83ea71e 100644
--- a/example/btrfs-subvolumes.nix
+++ b/example/btrfs-subvolumes.nix
@@ -1,25 +1,28 @@
{
- type = "devices";
- content = {
+ disk = {
vdb = {
- type = "table";
- format = "gpt";
- partitions = [
- {
- type = "partition";
- part-type = "primary";
- start = "0%";
- end = "100%";
- content = {
- type = "btrfs";
- mountpoint = "/";
- subvolumes = [
- "/home"
- "/test"
- ];
- };
- }
- ];
+ type = "disk";
+ device = "/dev/vdb";
+ content = {
+ type = "table";
+ format = "gpt";
+ partitions = [
+ {
+ name = "root";
+ type = "partition";
+ start = "0%";
+ end = "100%";
+ content = {
+ type = "btrfs";
+ mountpoint = "/";
+ subvolumes = [
+ "/home"
+ "/test"
+ ];
+ };
+ }
+ ];
+ };
};
};
}