summaryrefslogtreecommitdiffstats
path: root/example/btrfs-subvolumes.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2022-09-30 12:55:28 +0200
committerlassulus <lassulus@lassul.us>2022-10-02 16:41:02 +0200
commit9f7f23abdb161578316d94f45528fbf47982f4d9 (patch)
tree92134db7dbe059a7163571e50045b42798a2aea4 /example/btrfs-subvolumes.nix
parenta215a1975938fbc04ae8fb14e474304f3200e15c (diff)
add nixos tests for disko.config, extend/fix existing tests
Diffstat (limited to 'example/btrfs-subvolumes.nix')
-rw-r--r--example/btrfs-subvolumes.nix19
1 files changed, 16 insertions, 3 deletions
diff --git a/example/btrfs-subvolumes.nix b/example/btrfs-subvolumes.nix
index 83ea71e..9a22861 100644
--- a/example/btrfs-subvolumes.nix
+++ b/example/btrfs-subvolumes.nix
@@ -1,16 +1,29 @@
-{
+{ disks ? [ "/dev/vdb" ] }: {
disk = {
vdb = {
type = "disk";
- device = "/dev/vdb";
+ device = builtins.elemAt disks 0;
content = {
type = "table";
format = "gpt";
partitions = [
{
+ type = "partition";
+ name = "ESP";
+ start = "1MiB";
+ end = "128MiB";
+ fs-type = "fat32";
+ bootable = true;
+ content = {
+ type = "filesystem";
+ format = "vfat";
+ mountpoint = "/boot";
+ };
+ }
+ {
name = "root";
type = "partition";
- start = "0%";
+ start = "128MiB";
end = "100%";
content = {
type = "btrfs";