summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorlassulus <lassulus@lassul.us>2022-10-22 23:35:16 +0200
committerlassulus <lassulus@lassul.us>2022-10-23 11:36:56 +0200
commit5aa3ebcb998c1d489926e4f702ee98f5175240e6 (patch)
tree1d8f153d9580d3e447322cc651acdbe626b5655d /default.nix
parent271b00593ff11a36081f5cbbacc3aa4fdc0f5b1a (diff)
types: refactor topLevel into devices, move output generators to lib
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix14
1 files changed, 7 insertions, 7 deletions
diff --git a/default.nix b/default.nix
index 00333a8..3fe2bbb 100644
--- a/default.nix
+++ b/default.nix
@@ -4,18 +4,18 @@ let
eval = cfg: lib.evalModules {
modules = lib.singleton {
# _file = toString input;
- imports = lib.singleton { topLevel.devices = cfg; };
+ imports = lib.singleton { devices = cfg; };
options = {
- topLevel = lib.mkOption {
- type = types.topLevel;
+ devices = lib.mkOption {
+ type = types.devices;
};
};
};
};
in {
types = types;
- create = cfg: (eval cfg).config.topLevel.create;
- mount = cfg: (eval cfg).config.topLevel.mount;
- config = cfg: (eval cfg).config.topLevel.config;
- packages = cfg: (eval cfg).config.topLevel.packages;
+ create = cfg: types.diskoLib.create (eval cfg).config.devices;
+ mount = cfg: types.diskoLib.mount (eval cfg).config.devices;
+ config = cfg: types.diskoLib.config (eval cfg).config.devices;
+ packages = cfg: types.diskoLib.packages (eval cfg).config.devices;
}