summaryrefslogtreecommitdiffstats
path: root/default.nix
diff options
context:
space:
mode:
authorJörg Thalheim <joerg@thalheim.io>2022-08-17 14:20:44 +0200
committerJörg Thalheim <joerg@thalheim.io>2022-08-17 14:53:43 +0200
commit20bfa327503ca1d89ba26e621a0f588b5449b302 (patch)
tree128f1ce8585c38685a30defbe49de525357e2a97 /default.nix
parent2fc06462ce5c31d363686b110b42d653b6f8f366 (diff)
disko: get rid of impure imports
This is a backwards-incompatible change but it allows to pin nixpkgs, which is desirable especially in professional environments where reproduciblity is important.
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix6
1 files changed, 4 insertions, 2 deletions
diff --git a/default.nix b/default.nix
index 6d08b8d..6858c40 100644
--- a/default.nix
+++ b/default.nix
@@ -1,3 +1,5 @@
-{
- inherit (import ./lib) config create mount;
+{ lib ? (import <nixpkgs> {}).lib }: {
+ inherit (import ./lib {
+ inherit lib;
+ }) config create mount;
}