summaryrefslogtreecommitdiffstats
path: root/messages/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'messages/default.nix')
-rw-r--r--messages/default.nix32
1 files changed, 32 insertions, 0 deletions
diff --git a/messages/default.nix b/messages/default.nix
new file mode 100644
index 0000000..a1e03b9
--- /dev/null
+++ b/messages/default.nix
@@ -0,0 +1,32 @@
+with (import <nixpkgs> {}); let
+
+in yarn2nix-moretea.mkYarnPackage rec {
+ pname = "workadventuremessages";
+ version = "unstable";
+
+ src = fetchFromGitHub {
+ owner = "thecodingmachine";
+ repo = "workadventure";
+ rev = "284846e8a59ec0d921189ac3a46e0eb5d1e14818";
+ sha256 = "1f1vi226kas7x9y8zw810q5vg1ikn4bb6ha9vnzvqk9y7jlc1n8q";
+ } + "/messages";
+
+ # packageJSON = src + "/back/package.json";
+ # yarnLock = src + "/back/yarn.lock";
+ # NOTE: this is optional and generated dynamically if omitted
+ yarnNix = ./yarn.nix;
+
+ # pkgConfig = {
+ # grpc = {
+ # postInstall = ''
+ # install -D -m755 ${node-grpc-patched}/bin/grpc_node.node src/node/extension_binary/node-v72-linux-x64-glibc/grpc_node.node
+ # '';
+ # };
+ # };
+
+ buildPhase = ''
+ mkdir -p $out
+ HOME=$TMPDIR yarn --offline proto
+ find
+ '';
+}