summaryrefslogtreecommitdiffstats
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..ba68205
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,17 @@
+with import <nixpkgs> {}; {
+ env = stdenv.mkDerivation {
+ name = "playlist-tools";
+ buildInputs = [
+ ffmpeg
+ parallel
+ python35Packages.youtube-dl
+ sox
+ vorbisgain
+ mpv
+ ];
+ SSL_CERT_FILE="/etc/ssl/certs/ca-bundle.crt";
+ shellHook = ''
+ PATH=$PATH:${./bin}
+ '';
+ };
+}