summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/simple
diff options
context:
space:
mode:
Diffstat (limited to 'tv/5pkgs/simple')
-rw-r--r--tv/5pkgs/simple/default.nix2
-rw-r--r--tv/5pkgs/simple/ff.nix2
-rw-r--r--tv/5pkgs/simple/fzmenu/default.nix47
3 files changed, 26 insertions, 25 deletions
diff --git a/tv/5pkgs/simple/default.nix b/tv/5pkgs/simple/default.nix
index 6ba4fec8..9fb45dd1 100644
--- a/tv/5pkgs/simple/default.nix
+++ b/tv/5pkgs/simple/default.nix
@@ -1,4 +1,4 @@
-with import <stockholm/lib>;
+with import ../../../lib;
self: super:
diff --git a/tv/5pkgs/simple/ff.nix b/tv/5pkgs/simple/ff.nix
index ec20c4a2..4ce9c3c7 100644
--- a/tv/5pkgs/simple/ff.nix
+++ b/tv/5pkgs/simple/ff.nix
@@ -1,5 +1,5 @@
{ pkgs }:
pkgs.writeDashBin "ff" ''
- exec ${pkgs.firefoxWrapper}/bin/firefox "$@"
+ exec ${pkgs.firefox}/bin/firefox "$@"
''
diff --git a/tv/5pkgs/simple/fzmenu/default.nix b/tv/5pkgs/simple/fzmenu/default.nix
index 1f1b8284..634d8338 100644
--- a/tv/5pkgs/simple/fzmenu/default.nix
+++ b/tv/5pkgs/simple/fzmenu/default.nix
@@ -1,37 +1,38 @@
-{ lib, stdenv
-, runCommand
-, coreutils, dash, gnused, fzf, pass-otp, rxvt_unicode, utillinux, xdotool
-}:
+{ lib, pkgs, stdenv }:
-runCommand "fzmenu" {
+pkgs.runCommand "fzmenu" {
} /* sh */ ''
mkdir $out
cp -r ${./bin} $out/bin
substituteInPlace $out/bin/otpmenu \
- --replace '#! /bin/sh' '#! ${dash}/bin/dash' \
+ --replace '#! /bin/sh' '#! ${pkgs.dash}/bin/dash' \
--replace '#PATH=' PATH=${lib.makeBinPath [
- coreutils
- dash
- fzf
- gnused
- pass-otp
- rxvt_unicode
- utillinux
- xdotool
+ pkgs.coreutils
+ pkgs.dash
+ pkgs.fzf
+ pkgs.gnused
+ (pkgs.pass.withExtensions (ext: [
+ ext.pass-otp
+ ]))
+ pkgs.rxvt_unicode
+ pkgs.utillinux
+ pkgs.xdotool
]}
substituteInPlace $out/bin/passmenu \
- --replace '#! /bin/sh' '#! ${dash}/bin/dash' \
+ --replace '#! /bin/sh' '#! ${pkgs.dash}/bin/dash' \
--replace '#PATH=' PATH=${lib.makeBinPath [
- coreutils
- dash
- fzf
- gnused
- pass-otp
- rxvt_unicode
- utillinux
- xdotool
+ pkgs.coreutils
+ pkgs.dash
+ pkgs.fzf
+ pkgs.gnused
+ (pkgs.pass.withExtensions (ext: [
+ ext.pass-otp
+ ]))
+ pkgs.rxvt_unicode
+ pkgs.utillinux
+ pkgs.xdotool
]}
''