summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/simple/fzmenu/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'tv/5pkgs/simple/fzmenu/default.nix')
-rw-r--r--tv/5pkgs/simple/fzmenu/default.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/tv/5pkgs/simple/fzmenu/default.nix b/tv/5pkgs/simple/fzmenu/default.nix
index 35918ff7..1f1b8284 100644
--- a/tv/5pkgs/simple/fzmenu/default.nix
+++ b/tv/5pkgs/simple/fzmenu/default.nix
@@ -1,4 +1,7 @@
-{ coreutils, dash, gnused, fzf, pass-otp, runCommand, rxvt_unicode, stdenv, utillinux, xdotool }:
+{ lib, stdenv
+, runCommand
+, coreutils, dash, gnused, fzf, pass-otp, rxvt_unicode, utillinux, xdotool
+}:
runCommand "fzmenu" {
} /* sh */ ''
@@ -8,7 +11,7 @@ runCommand "fzmenu" {
substituteInPlace $out/bin/otpmenu \
--replace '#! /bin/sh' '#! ${dash}/bin/dash' \
- --replace '#PATH=' PATH=${stdenv.lib.makeBinPath [
+ --replace '#PATH=' PATH=${lib.makeBinPath [
coreutils
dash
fzf
@@ -21,7 +24,7 @@ runCommand "fzmenu" {
substituteInPlace $out/bin/passmenu \
--replace '#! /bin/sh' '#! ${dash}/bin/dash' \
- --replace '#PATH=' PATH=${stdenv.lib.makeBinPath [
+ --replace '#PATH=' PATH=${lib.makeBinPath [
coreutils
dash
fzf