summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/override
diff options
context:
space:
mode:
Diffstat (limited to 'tv/5pkgs/override')
-rw-r--r--tv/5pkgs/override/alacritty.nix16
-rw-r--r--tv/5pkgs/override/anbox.nix72
-rw-r--r--tv/5pkgs/override/default.nix4
-rw-r--r--tv/5pkgs/override/fzf/complete1.patch77
-rw-r--r--tv/5pkgs/override/fzf/default.nix7
-rw-r--r--tv/5pkgs/override/gitAndTools.nix5
-rw-r--r--tv/5pkgs/override/input-fonts.nix13
-rw-r--r--tv/5pkgs/override/iosevka-tv-1.nix20
-rw-r--r--tv/5pkgs/override/iosevka-tv-2.nix20
-rw-r--r--tv/5pkgs/override/jc.nix21
l---------tv/5pkgs/override/lib1
-rw-r--r--tv/5pkgs/override/uqmi.nix10
12 files changed, 0 insertions, 266 deletions
diff --git a/tv/5pkgs/override/alacritty.nix b/tv/5pkgs/override/alacritty.nix
deleted file mode 100644
index f864fff6..00000000
--- a/tv/5pkgs/override/alacritty.nix
+++ /dev/null
@@ -1,16 +0,0 @@
-self: super:
-
-super.alacritty.overrideAttrs (old:
- if self.lib.versions.majorMinor old.version == "0.12" then
- {
- version = "${old.version}-tv";
- src = self.fetchFromGitHub {
- owner = "4z3";
- repo = "alacritty";
- rev = "touchscreen-support-0.12";
- hash = "sha256-yDG7IeQUmJhKMJebhMDzHLb3UHGLcO1FVZnmGe5Xr9w=";
- };
- }
- else
- builtins.trace "not overriding alacritty because unsupported version" {}
-)
diff --git a/tv/5pkgs/override/anbox.nix b/tv/5pkgs/override/anbox.nix
deleted file mode 100644
index 39406173..00000000
--- a/tv/5pkgs/override/anbox.nix
+++ /dev/null
@@ -1,72 +0,0 @@
-self: super:
-
-# https://github.com/NixOS/nixpkgs/pull/125600
-super.anbox.overrideAttrs (old:
- assert old.version == "unstable-2020-11-29";
- rec {
- version = "unstable-2021-05-26";
-
- src = self.fetchFromGitHub {
- owner = old.pname;
- repo = old.pname;
- rev = "ad377ff25354d68b76e2b8da24a404850f8514c6";
- sha256 = "1bj07ixwbkli4ycjh41mnqdbsjz9haiwg2nhf9anbi29z1d0819w";
- fetchSubmodules = true;
- };
-
- postPatch = old.patchPhase;
-
- # patchPhase() from <nixpkgs/pkgs/stdenv/generic/setup.sh>
- # TODO patchPhase = default.patchPhase; or something
- patchPhase = ''
- runHook prePatch
-
- for i in ''${patches:-}; do
- header "applying patch $i" 3
- local uncompress=cat
- case "$i" in
- *.gz)
- uncompress="gzip -d"
- ;;
- *.bz2)
- uncompress="bzip2 -d"
- ;;
- *.xz)
- uncompress="xz -d"
- ;;
- *.lzma)
- uncompress="lzma -d"
- ;;
- esac
- # "2>&1" is a hack to make patch fail if the decompressor fails (nonexistent patch, etc.)
- # shellcheck disable=SC2086
- $uncompress < "$i" 2>&1 | patch ''${patchFlags:--p1}
- done
-
- runHook postPatch
- '';
-
- patches = [
- # Fixes compatibility with lxc 4
- (self.fetchpatch {
- url = "https://git.alpinelinux.org/aports/plain/community/anbox/lxc4.patch?id=64243590a16aee8d4e72061886fc1b15256492c3";
- sha256 = "1da5xyzyjza1g2q9nbxb4p3njj2sf3q71vkpvmmdphia5qnb0gk5";
- })
- # Wait 10× more time when starting
- # Not *strictly* needed, but helps a lot on slower hardware
- (self.fetchpatch {
- url = "https://git.alpinelinux.org/aports/plain/community/anbox/give-more-time-to-start.patch?id=058b56d4b332ef3379551b343bf31e0f2004321a";
- sha256 = "0iiz3c7fgfgl0dvx8sf5hv7a961xqnihwpz6j8r0ib9v8piwxh9a";
- })
- # Ensures generated desktop files work on store path change
- (self.fetchpatch {
- url = "https://raw.githubusercontent.com/NixOS/nixpkgs/fdf7b4be1a659ed8b96586c2fc8ff90850e25feb/pkgs/os-specific/linux/anbox/0001-NixOS-Use-anbox-from-PATH-in-desktop-files.patch";
- sha256 = "173z84g1r8h367a2dgk6945is6vxg4j1hs2hkfd3m3bbpwfw9221";
- })
- # Provide window icons
- (self.fetchpatch {
- url = "https://github.com/samueldr/anbox/commit/2387f4fcffc0e19e52e58fb6f8264fbe87aafe4d.patch";
- sha256 = "12lmr0kxw1n68g3abh1ak5awmpczfh75c26f53jc8qpvdvv1ywha";
- })
- ];
-})
diff --git a/tv/5pkgs/override/default.nix b/tv/5pkgs/override/default.nix
deleted file mode 100644
index 87b7ce92..00000000
--- a/tv/5pkgs/override/default.nix
+++ /dev/null
@@ -1,4 +0,0 @@
-with import ./lib;
-self: super:
-
-mapNixDir (path: import path self super) ./.
diff --git a/tv/5pkgs/override/fzf/complete1.patch b/tv/5pkgs/override/fzf/complete1.patch
deleted file mode 100644
index 3e3f2c4d..00000000
--- a/tv/5pkgs/override/fzf/complete1.patch
+++ /dev/null
@@ -1,77 +0,0 @@
-commit 57cbd76c068121b685399fdb4649e7ba537983d6
-Author: tv <tv@krebsco.de>
-Date: Mon Dec 5 15:24:30 2022 +0100
-
- Add --complete-1 option
-
-diff --git a/man/man1/fzf.1 b/man/man1/fzf.1
-index 79e7291..3b8a753 100644
---- a/man/man1/fzf.1
-+++ b/man/man1/fzf.1
-@@ -685,6 +685,9 @@ interactive finder and automatically select the only match
- If there is no match for the initial query (\fB--query\fR), do not start
- interactive finder and exit immediately
- .TP
-+.B "--complete-1"
-+Exit interactive finder when there's exactly one match
-+.TP
- .BI "-f, --filter=" "STR"
- Filter mode. Do not start interactive finder. When used with \fB--no-sort\fR,
- fzf becomes a fuzzy-version of grep.
-diff --git a/src/core.go b/src/core.go
-index 2ddddc3..09afff2 100644
---- a/src/core.go
-+++ b/src/core.go
-@@ -337,8 +337,14 @@ func Run(opts *Options, version string, revision string) {
- }
- determine(val.final)
- }
-+ } else {
-+ if opts.Complete1 && val.Length() == 1 {
-+ opts.Printer(val.Get(0).item.AsString(opts.Ansi))
-+ terminal.reqBox.Set(reqClose, nil)
-+ } else {
-+ terminal.UpdateList(val, clearSelection())
-+ }
- }
-- terminal.UpdateList(val, clearSelection())
- }
- }
- }
-diff --git a/src/options.go b/src/options.go
-index 5400311..1e38fe4 100644
---- a/src/options.go
-+++ b/src/options.go
-@@ -108,6 +108,7 @@ const usage = `usage: fzf [options]
- -1, --select-1 Automatically select the only match
- -0, --exit-0 Exit immediately when there's no match
- -f, --filter=STR Filter mode. Do not start interactive finder.
-+ --complete-1 Exit interactive finder when there's exactly one match
- --print-query Print query as the first line
- --expect=KEYS Comma-separated list of keys to complete fzf
- --read0 Read input delimited by ASCII NUL characters
-@@ -274,6 +275,7 @@ type Options struct {
- Query string
- Select1 bool
- Exit0 bool
-+ Complete1 bool
- Filter *string
- ToggleSort bool
- Expect map[tui.Event]string
-@@ -342,6 +344,7 @@ func defaultOptions() *Options {
- Query: "",
- Select1: false,
- Exit0: false,
-+ Complete1: false,
- Filter: nil,
- ToggleSort: false,
- Expect: make(map[tui.Event]string),
-@@ -1546,6 +1549,8 @@ func parseOptions(opts *Options, allArgs []string) {
- opts.Exit0 = true
- case "+0", "--no-exit-0":
- opts.Exit0 = false
-+ case "--complete-1":
-+ opts.Complete1 = true
- case "--read0":
- opts.ReadZero = true
- case "--no-read0":
diff --git a/tv/5pkgs/override/fzf/default.nix b/tv/5pkgs/override/fzf/default.nix
deleted file mode 100644
index 2254d455..00000000
--- a/tv/5pkgs/override/fzf/default.nix
+++ /dev/null
@@ -1,7 +0,0 @@
-self: super:
-
-super.fzf.overrideAttrs (old: {
- patches = old.patches or [] ++ [
- ./complete1.patch
- ];
-})
diff --git a/tv/5pkgs/override/gitAndTools.nix b/tv/5pkgs/override/gitAndTools.nix
deleted file mode 100644
index a460773b..00000000
--- a/tv/5pkgs/override/gitAndTools.nix
+++ /dev/null
@@ -1,5 +0,0 @@
-self: super:
-
-super.gitAndTools // {
- inherit (self) diff-so-fancy;
-}
diff --git a/tv/5pkgs/override/input-fonts.nix b/tv/5pkgs/override/input-fonts.nix
deleted file mode 100644
index 6ee7afac..00000000
--- a/tv/5pkgs/override/input-fonts.nix
+++ /dev/null
@@ -1,13 +0,0 @@
-self: super:
-
-super.input-fonts.overrideAttrs (old: rec {
- src = self.fetchzip {
- url = "http://xu.r/~tv/mirrors/input-fonts/Input-Font-2.zip";
- sha256 = "1q58x92nm7dk9ylp09pvgj74nxkywvqny3xmfighnsl30dv42fcr";
- stripRoot = false;
- };
- sourceRoot = null;
- outputHash = null;
- outputHashAlgo = null;
- outputHashMode = null;
-})
diff --git a/tv/5pkgs/override/iosevka-tv-1.nix b/tv/5pkgs/override/iosevka-tv-1.nix
deleted file mode 100644
index 880160b3..00000000
--- a/tv/5pkgs/override/iosevka-tv-1.nix
+++ /dev/null
@@ -1,20 +0,0 @@
-self: super:
-
-let
- srcpkg = super.iosevka-tv-1;
- binpkg = self.fetchzip {
- inherit (srcpkg) pname version;
- stripRoot = false;
- hash = "sha256-QIuTS70vUQSvDDXjY4uI6SCcu1XT4HjvzpthvrNX4h0=";
- urls = [
- "https://c.krebsco.de/${srcpkg.name}.tar.gz"
- "https://ni.krebsco.de/~tv/mirrors/iosevka/${srcpkg.name}.tar.gz"
- ];
- };
-in
-
-if srcpkg.version == binpkg.version then
- binpkg
-
-else
- srcpkg
diff --git a/tv/5pkgs/override/iosevka-tv-2.nix b/tv/5pkgs/override/iosevka-tv-2.nix
deleted file mode 100644
index 2eecf3cf..00000000
--- a/tv/5pkgs/override/iosevka-tv-2.nix
+++ /dev/null
@@ -1,20 +0,0 @@
-self: super:
-
-let
- srcpkg = super.iosevka-tv-2;
- binpkg = self.fetchzip {
- inherit (srcpkg) pname version;
- stripRoot = false;
- hash = "sha256-PuIrW1ftYD5PW4du6gq1XpUM3v0potwmj+vAxJImF/A=";
- urls = [
- "https://c.krebsco.de/${srcpkg.name}.tar.gz"
- "https://ni.krebsco.de/~tv/mirrors/iosevka/${srcpkg.name}.tar.gz"
- ];
- };
-in
-
-if srcpkg.version == binpkg.version then
- binpkg
-
-else
- srcpkg
diff --git a/tv/5pkgs/override/jc.nix b/tv/5pkgs/override/jc.nix
deleted file mode 100644
index 346dd3ee..00000000
--- a/tv/5pkgs/override/jc.nix
+++ /dev/null
@@ -1,21 +0,0 @@
-self: super:
-
-let
- version = "1.21.0";
-in
-
-# Prevent downgrades.
-assert self.lib.versionAtLeast version super.jc.version;
-
-self.python3.pkgs.toPythonApplication
- (self.python3.pkgs.jc.overrideAttrs
- (oldAttrs: {
- name = "jc-${version}";
- version = version;
- src = self.fetchFromGitHub {
- owner = "kellyjonbrazil";
- repo = "jc";
- rev = "v${version}";
- sha256 = "sha256-kS42WokR7ZIqIPi8LbX4tmtjn37tckea2ELbuqzTm2o";
- };
- }))
diff --git a/tv/5pkgs/override/lib b/tv/5pkgs/override/lib
deleted file mode 120000
index dc598c56..00000000
--- a/tv/5pkgs/override/lib
+++ /dev/null
@@ -1 +0,0 @@
-../lib \ No newline at end of file
diff --git a/tv/5pkgs/override/uqmi.nix b/tv/5pkgs/override/uqmi.nix
deleted file mode 100644
index 1eaecbd6..00000000
--- a/tv/5pkgs/override/uqmi.nix
+++ /dev/null
@@ -1,10 +0,0 @@
-self: super:
-
-super.uqmi.overrideAttrs (old: {
- version = "unstable-2022-05-04";
- src = self.fetchgit {
- url = "https://git.openwrt.org/project/uqmi.git";
- rev = "56cb2d4056fef132ccf78dfb6f3074ae5d109992";
- hash = "sha256-PwnR24PbNKfLrsBlU5JTOHDzs/9Wgcuwfnu3dJuuZcM=";
- };
-})