summaryrefslogtreecommitdiffstats
path: root/tv/5pkgs/override
diff options
context:
space:
mode:
Diffstat (limited to 'tv/5pkgs/override')
-rw-r--r--tv/5pkgs/override/default.nix13
-rw-r--r--tv/5pkgs/override/nix-prefetch-github.nix47
2 files changed, 60 insertions, 0 deletions
diff --git a/tv/5pkgs/override/default.nix b/tv/5pkgs/override/default.nix
index 99c1b3ec..d18d6650 100644
--- a/tv/5pkgs/override/default.nix
+++ b/tv/5pkgs/override/default.nix
@@ -1,5 +1,18 @@
with import <stockholm/lib>;
self: super: {
+ input-fonts = super.input-fonts.overrideAttrs (old: rec {
+ src = self.fetchurl {
+ url = "http://xu.r/~tv/mirrors/input-fonts/Input-Font-2.zip";
+ sha256 = "1vvipqcflz4ximy7xpqy9idrdpq3a0c490hp5137r2dq03h865y0";
+ };
+ outputHash = null;
+ outputHashAlgo = null;
+ outputHashMode = null;
+ });
+
+ nix-prefetch-github =
+ self.python3Packages.callPackage ./nix-prefetch-github.nix {};
+
rxvt_unicode = self.callPackage ./rxvt_unicode.nix {
rxvt_unicode = super.rxvt_unicode;
};
diff --git a/tv/5pkgs/override/nix-prefetch-github.nix b/tv/5pkgs/override/nix-prefetch-github.nix
new file mode 100644
index 00000000..67873f92
--- /dev/null
+++ b/tv/5pkgs/override/nix-prefetch-github.nix
@@ -0,0 +1,47 @@
+{ fetchPypi
+, lib
+, buildPythonPackage
+, pythonOlder
+, attrs
+, click
+, effect
+, jinja2
+, git
+, pytestCheckHook
+, pytest-black
+, pytestcov
+, pytest-isort
+}:
+
+buildPythonPackage rec {
+ pname = "nix-prefetch-github";
+ version = "3.0";
+
+ src = fetchPypi {
+ inherit pname version;
+ sha256 = "sha256-EN+EbVXUaf+id5UsK4EBm/9k9FYaH79g08kblvW60XA=";
+ };
+
+ propagatedBuildInputs = [
+ attrs
+ click
+ effect
+ jinja2
+ ];
+
+ checkInputs = [ pytestCheckHook pytest-black pytestcov pytest-isort git ];
+ checkPhase = ''
+ pytest -m 'not network'
+ '';
+
+ # latest version of isort will cause tests to fail
+ # ignore tests which are impure
+ disabledTests = [ "isort" "life" "outputs" "fetch_submodules" ];
+
+ meta = with lib; {
+ description = "Prefetch sources from github";
+ homepage = "https://github.com/seppeljordan/nix-prefetch-github";
+ license = licenses.gpl3;
+ maintainers = with maintainers; [ seppeljordan ];
+ };
+}